Sie sind nicht angemeldet.

Wie bekomme ich Zugriff aufs Cartmoddingforum | Fire Emblem: Das Siegelschwert Übersetzer gesucht | Videotutorial - Spielpatches benutzen! | Spenden für die Seite

nones

Ich übe noch

  • »nones« ist männlich
  • »nones« ist der Autor dieses Themas

Beiträge: 2

  • Nachricht senden

1

Donnerstag, 22. März 2018, 08:28

TSOP56 Flash (S29GL064N) mit TL866A und Adapter auslesen, aber wie?

Moin,

ich habe hier das Problem das ich einen Spansion (nun Cypress) S29GL064N Flash auslesen und beschreiben möchte.
Dieser hat ein TSOP56 Gehäuse und kann nicht direkt in den Programmer eingesteckt werden (ZIF40 DIL Sockel). Interessanterweise kann man ihn aber in der Chipliste auswählen, jedoch nur als TSOP48.
Dafür ist von Autoelectric ein Adapter vorgesehen, welchen ich mir zugelegt habe:
index.php?page=Attachment&attachmentID=556
Der hat zusätzliche Lateches drauf. Auf die beiden Pfostenleisten wird dann ein passender Gehäuseadapter gesteckt. Die beiligenden sind für mich aber alle unbrauchbar. Es gibt zwar einen SOP56 aber da könnte ich meinen Chip nichtmal drauflöten, weil der TSOP56 viel breiter ist. Weiterhin kann das Pinout meiner Meinung nach nicht stimmen, weil auf dem SOP56 Adapter für die Funktion wesentliche Pins garnicht beschaltet sind. Ist vielleicht für andere Chips gedacht?!

Jedenfalls habe ich noch einen TSOP56 ZIF-Sockel mit Pfostenleisten und hätte die Idee gehabt die mit Dupont-Wires zum Adapter zu verbinden. Ich finde jedoch nirgends ein Pinout für den o.g. Latch-Adapter und seine beiden doppelreihigen Pfostenleisten. Damit wüsste ich auch nicht welche Pins des Flash ich mit welchen des Adapters verbinden müsste. Da der TL866 universell ist und seine Pins keine feste Funktion haben (sprich, sie richten sich nach dem gewählten Chip in der Software) müsste ich ja wissen welchen Pin die Software wie anspricht und wo dieser am Adapter zu finden ist.

Für mich aktuell ein großes Fragezeichen, da ich keinerlei Unterlagen finden kann.
»nones« hat folgende Datei angehängt:

RedScorpion

Abteilungsleiter

  • »RedScorpion« ist männlich

Beiträge: 2 783

Danksagungen: 445

  • Nachricht senden

2

Donnerstag, 22. März 2018, 08:49

Grüße,

was willst du den final eigentlich mit dem Chip realisieren?! Ich hab mich vor einiger Zeit auch mal damit beschäftigt und statt 56pin nur die 48er genutzt. Die 29XX064 Speicher, egal von welcher Firma haben in der Regel alle das gleiche Pinout und auch die gleiche Syntax zum beschreiben.

Das Pinout von dem Adapter wirst du nirgends finden, glaub ich mal.

Was interessant ist:

http://www.ezoflash.com/adapters/tsop48d3/tsop48d3.htm


Die Pins am 56er sind glaube ich mehrfach NC oder? 1,2,27,28,29.30 und 55,56.

Du müsstest einen freien Adapter 56 pin TSOP Adapter nehmen, den Adapter oben anpassen auf den TL und dann sollte es gehen!

Gruß

red

nones

Ich übe noch

  • »nones« ist männlich
  • »nones« ist der Autor dieses Themas

Beiträge: 2

  • Nachricht senden

3

Donnerstag, 22. März 2018, 12:29

Zum Ziel: Der Chip befindet sich auf einem TFT-Treiberboard. Davon habe ich zwei und eines hat nen Fehler. Ich habe das ganze soweit isoliert das beim Tausch der Flash-Chips der Fehler "mitwandert". Also ist entweder das Flash in Teilen defekt oder die Daten darin. Hierzu muss ich den Flash des funktionierenden auslesen und in einen neuen leeren programmieren. Fabrikneue Flashes habe ich mir bereits besorgt.

Die 56 und 48 Pin Variante vom S29GL064 unterscheidet sich in der Tat nur durch 8 außen liegenden NCs (einer davon ist Vio, aber unrelevant). Hab auch schon überlegt einen Standard-Adapter zu nehmen und mit Dupont-Wires auf den TSOP48 zu verbinden. Diesen müsste ich aber erstmal ausmessen um zu wissen welcher Pin vom ZIF-Sockel auf welchen von den Pfostensteckern geht...

RedScorpion

Abteilungsleiter

  • »RedScorpion« ist männlich

Beiträge: 2 783

Danksagungen: 445

  • Nachricht senden

4

Donnerstag, 22. März 2018, 15:12

Hmm, das natürlich doof, da du ja erstmal einen 56er TSOP Adapter brauchst um auszulesen. Gibts denn die Daten auf dem "defekten" chip nicht als Backup irgendwo im NEtz?

Gruß

red

Zurzeit ist neben Ihnen 1 Benutzer in diesem Thema unterwegs:

1 Besucher

Thema bewerten